Browser Compatibility SCC
In order to optimize the usage of our SWARM Control Center, you need to use one of the recommended and supported browsers below.
The SWARM Portal is a web-based application and runs in the browser of all modern desktops and tablet devices. To use the portal login to your SCC, you must have JavaScript enabled on your browser.
We recommend using the most up-to-date browser that's compatible with your operating system. The following browsers are supported:

Why should you stop using older browser versions?

Newer browser versions are generally the safest, as they lower the chance of intrusion and other security risks. Older browsers and operating systems are not recommended since they do not always support the operation and security of our Control Center. We do not support older, out-of-date versions or browsers not mentioned below.
We test new browser versions to ensure they work properly with our websites, although not usually right away after they are released.
Last modified 1mo ago
Export as PDF
Copy link
Contents